Can’t locate HTTP/Request/Common.pm エラーの対応

とあるPerlスクリプトを動かしたところ Can’t locate HTTP/Request/Common.pm のエラーが。具体的には下記のように表示されました。

言わずもがな関連するモジュールがインストールされていないことが原因です。

Can’t locate HTTP/Request/Common.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /usr/local/hogehoge.pl line 57.
BEGIN failed–compilation aborted at /usr/local/hogehoge.pl line 57.

解決策:perl-libwww-perlをインストール

yum にて perl-libwww-perl をインストールすれば解決します。

$ yum install perl-libwww-perl

これで完了。

コメントを残す

メールアドレスが公開されることはありません。