Database linkのimpdpでORA-39113エラーが発生した原因

Oracle Database SE 10.2.0.1 から Oracle 11.2.0.1 にDatabase Linkを利用したimpdp (NETWORK_LINK) でORA-39113エラー「データベース・バージョンを判別できません」が発生してしまいました。

Import: Release 11.2.0.1.0 - Production on 金 12月 12 15:28:51 2014

Copyright (c) 1982, 2009, Oracle and/or its affiliates.  All rights reserved.

接続先: Oracle Database 11g Release 11.2.0.1.0 - 64bit Production
ORA-39006: 内部エラーが発生しました。
ORA-39113: データベース・バージョンを判別できません
ORA-04052: リモート・オブジェクトSYS.DBMS_UTILITY@LINK_HOGEの検索中にエラーが発生しました。
ORA-00604: 再帰SQLレベル3でエラーが発生しました。
ORA-06544: PL/SQL: 内部エラーです。引数: [55916], [], [], [], [], [], [], []
ORA-06553: PLS-801: 内部エラー[55916]
ORA-02063: 先行のエラー・メッセージを参照してください2 lines(LINK_HOGE)。

ORA-39097: データ・ポンプ・ジョブで予期しないエラー-4052が見つかりました

いろいろと確認をしたところ、どうやら10g R2(下位)から11g R2(上位)へのデータベースリンク・インポートを利用するには 10.2.0.2以上が必要っぽいですね‥。

http://www.oracle.com/jp/system-requirement/interoperability-support-195844-ja.html

コメントを残す

メールアドレスが公開されることはありません。